Microsoft 365 outage affecting verification codes

Incident Report for Momice status page

Postmortem

Post-Mortem: Microsoft 365 Verification Code Delivery Incident

Severity: To be confirmed
Incident start: September 4, 2026 – 11:32 CEST
Resolved: September 5, 2026 – 15:00 CEST
Affected component: Email verification code delivery
External dependency: Microsoft 365
RCA owner: To be assigned

Summary

On September 4, we identified an issue affecting the delivery of verification codes to customers using Microsoft 365 email services.

The disruption originated with Microsoft 365 and resulted in verification emails being delayed or not delivered. This prevented some affected customers from completing actions that required an email verification code.

During the incident, Microsoft reported an active issue with its services. We monitored both Microsoft's status and our email delivery metrics. During the afternoon of September 4, we observed a significant improvement in delivery performance, although Microsoft continued to report an active issue.

The Microsoft 365 service subsequently recovered, and the incident was resolved on Saturday, September 5 at approximately 15:00 CEST.

Customer Impact

Customers using Microsoft 365 as their email provider may have experienced delayed or missing verification codes.

For affected customers, this meant they could not complete workflows requiring email verification until the verification email was successfully delivered.

Customers using unaffected email providers were not impacted by the Microsoft 365 delivery issue.

Components Involved

  • Momice verification code/email service
  • Email delivery provider
  • Microsoft 365 email infrastructure

Root Cause — Trigger, Fault, Gap

Trigger:
An external service disruption occurred within Microsoft 365, affecting email delivery to Microsoft-hosted mailboxes.

Fault:
Verification emails sent to affected Microsoft 365 recipients were delayed or could not be successfully delivered during the disruption.

Gap:
The verification process depends on customers receiving an email containing their verification code. When an external email provider experiences a delivery disruption, affected customers have limited ability to complete verification until email delivery recovers.

The underlying technical cause of the Microsoft 365 outage was outside Momice's infrastructure and control.

Detection

The issue was reported at 11:32 CEST on September 4. Following the report, we monitored our email delivery performance alongside Microsoft's service status.

Later that day, our delivery metrics showed substantial recovery, including an improvement in successful retries. Because Microsoft continued to report an active issue, we kept the incident open and continued monitoring rather than immediately declaring it resolved.

Resolution

No direct remediation to Microsoft 365 infrastructure was possible from the Momice side.

We continued monitoring email delivery while Microsoft worked to restore its services. Once Microsoft 365 recovered, verification code delivery returned to normal.

Following continued monitoring, the incident was considered resolved on September 5 at approximately 15:00 CEST.

Follow-up Actions

We will review this incident to determine whether we can further reduce the customer impact of future email-provider outages. Potential follow-up actions include:

  • Review monitoring and alerting for verification email delivery by recipient email provider.
  • Assess whether customers can be given clearer guidance when verification emails are delayed by an external provider.
  • Review whether alternative verification or recovery mechanisms would be appropriate during prolonged email-provider disruptions.
  • Document the escalation and communication process for future third-party email delivery incidents.

Any resulting actions will be tracked through the appropriate internal tickets.

Status

Resolved. Verification code delivery to Microsoft 365 recipients has returned to normal.

Posted Sep 07, 2026 - 09:20 CEST

Resolved

This incident has been resolved.
Posted Sep 05, 2026 - 13:32 CEST

Monitoring

Monitoring
Updated: September 4, 2026 – 13:44 CEST

We are seeing signs of recovery in Microsoft 365 email delivery. Delivery performance has improved significantly, indicating that Microsoft’s services are returning toward normal operation.

Microsoft is still reporting an active issue and continues to work on the underlying problem. Customers may therefore still experience occasional delays when receiving verification codes.

We will continue to monitor the situation and provide another update once Microsoft confirms that the issue has been fully resolved.

Affected service: Verification code delivery via Microsoft 365
Posted Sep 04, 2026 - 13:47 CEST

Investigating

Investigating
Reported: September 4, 2026 – 11:32 CEST

We are currently experiencing an issue related to a Microsoft 365 outage that is affecting the delivery of verification codes.

As a result, customers using Microsoft 365 email services may experience delays or may not receive verification codes, which could prevent them from completing actions that require email verification.

We are monitoring the situation and will provide an update as soon as more information becomes available.

Affected service: Verification code delivery via Microsoft 365

We apologize for the inconvenience and appreciate your patience.
Posted Sep 04, 2026 - 11:49 CEST
This incident affected: Tool.